A weird glitch in creating

I tried placing a coin and then I test collecting and then I do it again and some coins are gone! I go back into the editor and they’re back but it’s stuck there, it won’t let me edit it. I can see the coins in the editor but not in the actual game! Someone help me please, I think it’s a weird glitch! Please, some help me!

can you send a link to your game?

Sure. Just to see.

Link: https://flowlab.io/game/play/948355

I don’t see any coins in the editor, but sometimes the sprites do that because of a glitch. Normally, reloading the level makes it work fine for me.

I just realized that glitch happened because I used the “Destroyer” behavior. But, I kept editing the game, that’s why there’s no coins. But, I fixed it by using different behaviors.

The game’s a Work-In-Progress.

Another glitch is I keep going inside the blocks. Help me.

what sort of glitch?

Use this link just to see. https://flowlab.io/game/play/948355

I keep going inside the blocks, like getting stuck under them.