Art positioning bug?

So I working on a menu design for my game, but I wanted the object to cover the whole background, which is 16x32. But when I used the move tool to move the art I had so far into the bottom right corner to work on other details, it only moves a selected part, and when I move it around it starts copying a bunch of extras. As if I took a paintbrush and kinda spreaded around a specific color.

Not sure if this is happening to anyone else, but I tried refreshing the page and using the selector tool to select the whole thing, but when I go to move it, it still bugs out like this. Thank goodness that the undo button works or else I would have been pretty upset over this.


So I figured out what was wrong. When I zoomed out all the way and tried moving it, it started to bug out like this, but when I zoomed back it, it moved the whole thing. Moving it was a bit difficult because I had to stare at it microscopic and align it to the correct corner, since it was a pretty large sprite. I was still able to find a way around it, but this still was kind of annoying and hopefully has a solution.


Ok, I’ll see if I can reproduce this and try to fix it. I’ve added it to Trello as well, so it doesn’t get lost. Just to be clear, to trigger this bug I just need to:

  1. Make a large (16x32) sprite
  2. Zoom out all the way
  3. Use the move to to try and move it around

and that will cause the problem?


That basically was it. I don’t know if it has to be a large sprite though, I think it has something to do with the fact that I was zoomed out all of the way, but it might have contributed to it.


This did happen to me, just a few hours ago. Sorry, I forgot to report it, I always forget to report bugs-

It also happened to me when adjusting the size of the sprite. If it zooms out too far on a large sprite it happens as well.

1 Like

Ok, thanks for reporting these issues :+1:

1 Like