Camera doin' something janky

I’m using a moveCamera behavior, and it’s not working… look in the code, play the (somewhat) game, and please tell me if you find anything.

1 Like

What do you mean by, “not working”?
The camera is moving with the player objects just fine.
Is there a specific time or space that the player enters which causes the problem?


This is supposed to happen:
Go to the first door. Press E and go up with the camera. Go to the second door. Press E and go down with the camera. For some reason, the down code is repeating itself and going down twice, but only for the camera…

I might just be stupid but I think this is a legitimate bug with flowlab, I don’t see anything wrong with your code.

I tested a few things:

  • I changed the value of the third number behavior (from top to bottom) to 0, this fixed the problem, temporarily.

  • I added another door on starting floor to go down, it did not move the camera, this shows that it is changing the camera but only when I was on the floor above the starting floor.

  • I also found that if you jumped down from the floor above the starter floor and went through the door that brought you up, the position of the camera did not change but the player’s position did.

    • Basically, the camera did not change even though the position of the player did.

TL;DR - I think flowlabs just bugged, the move x/y nodes dose the same thing as the set x/y nodes, you might need to ask grazer or someone more eligible to dig through flowlabs code and see what the problem is.


Yeah, I just used a set variable instead of a move. This makes it so my game is more restricted in the amount of stories (in a house) it has :frowning:
@grazer you should look into this.

Yayy I created a fun little thing now you can kinda teleport using the doors!

1 Like

Hey, I made some fancy art for the game. Just for funsies! :upside_down_face:
pixil-frame-0 (4)


Nice, it looks really good!


Is this still not working? I just looked at it and it seems ok.

1 Like

I fixed it, but the move camera wasn’t working. I had to use a set camera pos instead

1 Like