Clicking behavior acting up

So I have two objects with the same bundle. Everything appears to work. But for some reason when the click behavior goes off in one of them, it doesn’t actually trigger. Idk if this is a known issue. But i’ve tried everything and it won’t trigger. It’s happening to 4 of my objects of the same type.

try making an input for them so they can both use the same trigger

There is only one trigger, it’s within the bundle that multiple different object types use. yet 4 of those style of objects have this issue. It’s very strange, considering they still get clicked and still do what they should, but the same clicking trigger is supposed to turn off a switch and it doesn’t.


still no use, i’ve even tried a different computer :frowning:

I’m pretty sure you can only have one clicking behavior per object. I had a similar issue in one of my projects.
A good fix is to have one click behavior send a message to itself and have any code you need to run activate when that message is sent.

Edit: here is a quick example I made

1 Like

This is true, I found a way around my issue, but this is good to show as the solution :slight_smile:

I’ve noticed this too, and really its just only allows one click behavior set to that object. You can have another behavior if the click is set to click anywhere. But this is overall still pretty annoying.