Flowlab freezes when using the object value behavior

Whenever I try to create a new value and try to change the name flow lab entirely freezes and I have to refresh, often times losing work. To specifically recreate it, you have to start highlighting the default text and drag until the cursor is outside of the new value box, then stop dragging.
image

3 Likes

This has happened to me many times before, I have no idea how to reproduce it though.

3 Likes

I would definitely like to fix this, but I can’t seem to reproduce it. Highlighting the name and dragging the mouse around doesn’t seem sufficient - is there anything else that you can think of that is a common factor?

How easy & reliable is it to reproduce?

4 Likes

No, it very rarely ever happens. It forces you to reload. It’s extremely difficult to reproduce.

2 Likes

If you see it again and you think about it, please check the browser console for an error message - that might be enough for me to fix it.

3 Likes

@grazer I got it again and finally remembered the take a screenshot

Edit: The error reads as

Uncaught TypeError: Cannot read properties of null (reading ‘get_frameRate’)

Thanks for the error message @DraftyScienceCoat75 !

If you think about it next time you find an error, before taking the screenshot if you can click the “Console” tab at the top (it looks like “Elements” is highlighted right now), it will provide a bit more context for me :+1:

This is helpful though, so thanks :slight_smile:

1 Like

oh I didn’t even see that lol

Got it I think, I still have the page open if there is some other message you could use


@grazer

1 Like

Thanks for the extra details :slight_smile:

Do you know how to trigger this error, or it just seems to happen randomly?

The only thing consistent I’ve noticed is that I highlight the text and I release the mouse1 button outside of the text box