Glitch with 2x2 blocks.

Whenever I exit out of my gaem editor, all blocks that are 2x2 revert to 1x1 (size.)

Before leaving tab:
After leaving tab and reopening tab:

Why is this happening @grazer ?

(btw the links are images)

Do you have a link to your game?

hey, this happens to me too, with all sizes larger than 1x1.
someone suggested to leave the tab open for a bit to make sure it saves the size of the object, which works sometimes, but i still think it might be an issue that needs fixing.

@TinkerSmith not to be rude, but how would it help? idk it seems like a global problem, you can try it on a test game

@“marinisyes”, he is asking for the link to the game so that he can see what you are seeing, and so that he can investigate further. Sometimes, problems cannot be solved by just images and descriptions. Not saying that your images are useless, but providing a link to your game will speed up the progress of getting the problem fixed. Also, not every issue can be easily replicated by other people, even with an explaination.

@Superstargames Alright, heres the link @TinkerSmith

@martinisyes , sorry, I was not able to replicate this. I tried it on mobile and on my PC, works fine.
I go into the editor, change the size from 32x32 to 64x64, fill the new empty area with that blue, return to the game and all runs fine.

Can anyone else replicate his problem?

Yeah, this is a background layer bug I found a little while ago and have it written down.
After fixing the 4x4 object, just move it to another spot and move it back and that should fix it.

@“JR 01” oof, didnt work, also its not just backround. its all layers

Then its a separate problem that I can’t test, its likely to be user/game specific or possibly a internet/editor saving problem.

Only thing else is to press play and edit the description and see if it saves. It may also help if you clear your browser’s cache/cookies.