How to equip items?

I have a character that I want to attach a crown onto. the thing is, the character is 2 blocks tall and three wide. Also, I don’t know how to do that in the first place. I don’t want to use an animation, because I’d have to do a ridiculously complicated command. please help.
https://flowlab.io/game/view/579742 Thanks. I’d appreciate it.

Have a 2 by 3 object called “crown” and draw a crown where the head is on the player. You may add non-movement related behaviors to it

Then in the behaviors of the player, take a trigger (like a collision with a powerup) and connect it to an “attach” behavior and set it to crown. Turn on match rotation if you want it to flip when the player turns or rotates

Okay… I made the 2x3 object, I applied the character sprite, drew the crown on, erased the character, and had a sprite, but it’s not working correctly. it doesn’t turn with me, nor is it on teh character’s head… Capture
did I do something wrong?

Capture1

Here’s what it looks like when equipped.

That’s funny, I’ll have to try some things and see if I can’t find a workaround for you.

Maybe make the crown match the characters sprite (so it will basically have the same hit box, and will align with the player) but have a once connected to an animation, and the animation has the crown in it.

Try that and tell me what happens

uhhh…
Screenshot 2017-01-22 at 3.57.12 PM
lol?

._.

It looks like it got fixed in the latest update. thanks, it works now. :smile:
Screenshot 2017-01-29 at 7.41.20 AM

Yeah, so it’s not fixed yet, but it may work sometimes depending on the display order. Here’s the issue:

Your dragon (Jelly) has a MouseClick trigger. When Jelly overlaps with the button on the Alert, depending on the display order, the mouse clicks may go to Jelly instead of the Alert button.

I’m going to fix this issue, but in the meantime you can avoid it by deleting the MouseClick trigger in Jelly. It’s not connected to anything, so I suspect that it isn’t actually supposed to be there anyway.

Yeah. I’m lazy, so I just left it there. XD Thanks.
(It worked.)

Also, My Armor equipment keeps flickering behind and in front of Jelly. is this a bug?
(It looks pretty darn cool when it works tho :wink: )

try moving the armor into parallax 2. It’s in the properties zone

Solves all my problems :wink: