I'm having multiple sound issues

<in my game, In the level called “cutscene3” the beeping noise overlaps over and over, and even after going to the next level, and quitting out of the game the noise continues. until the tab is closed. >the other issue I’m having is when the player hits the ground, a sound effect is supposed to play, but it doesn’t. everything is set up how it was before, but It just stopped working.

Make sure you didn’t change the object’s names. For some blocks you have to re-select the objects if you changed the names.

Make sure that you didn’t do an always – play [sound] because it will endlessly repeat.

I’m almost sure those aren’t the problems, because It was set up the exact same as it was before, when everything worked. and I haven’t changed any objects names in a long time.

Hm, no idea then, sorry that I can’t help!

Maybe ask grazer?

1 Like

maybe, I don’t want to bother him if he’s busy, but I guess I should ask.


1 Like

I have this issue often with my games. I don’t know exactly what your problem is, but mine were fixed when I had all the automatic timers become activated by once blocks instead of automatically.

I think I found the problem for the first one. It’s because you have loop on for the sound block. I tested it without loop and it worked for me.


Thanks! I didn’t think I had it on loop but I guess i did

I’ll fix it as soon as I can.


No problem, for the other problem, what is the sound effect called?

1 Like

I think it’s swords, but I don’t remember which one. It should be in the Run & jump bundle, connected to a bunch of logic gates and ray casts. The problem is most likely somewhere in there, but it might also just be a bug in the website.

Thanks for helping me with this btw


I looked into it, and found that it’s not working because the switch below the “grassworld mailbox” is off. If you just turn that switch on, it fixes it. For some reason the switches are bugged, so if you delete the switch to the right of the same mailbox, it fixes it for the grassland world too.


Huh. That’s odd. I never would have thought of that, thanks!