Impulse is broken

When trying to impulse an object in my game it first shoots it down for an odd reason

Link, screenshot or video? I have no way of helping you without something to go off of

i changed it to motor because it seems to make it smoother, but the same problem happens

Spent some more time and finally sort of fixed it, with the help of noise cancelling headphones

Nvm, reloaded and now it’s worse, it keeps randomizing how broken it wants to be, wish this website could decide to work

figured the problem out, when setting the motor to x it worked, and when being set to forwards it does not work even though it’s forwards is the same as x.

1 Like

I’m not sure what the problem is, everything seems to work as intended on my side

Edit: nevermind, I didn’t see that last comment. Good job :+1:

when throwing it would make the ball teleport down and it would sometimes go backwards along with randomly shooting upwards but changing it to x fixed it for some odd reason

1 Like

X is the left/right trigger, Y is up and down.

1 Like

yes, i know but when it was on forwards it broke it, even though it had it’s forwards as right

1 Like

Forward is never as precise as the x and y values, I’d recommend always using them instead of forward. Except in a few special occasions

well yes, but i was trying to make it shoot in the direction of yuor mouse so you had more control, yet it broke it

1 Like

Impulse is not broken, Forward is not broken, and nothing about either of them is random. I don’t mind helping out, but please consider the possibility that if they don’t behave the way you expect, it might be the case that your expectations could be at fault.



1 Like