Is Deck building possible?

I’d hope so, but it’s not terrible if that’s a lot of work. One deck is fine.

So I made multiple decks in Gods of Five

The whole system for that was however many save files you want, each save file containing 6 different deck options. That gets into quite a bit of complexity, but just the decks is alright.

So what you want to do is convert the Number List to a Text List, and each option in the Text List would be an entire Deck.
Then you would select one of the decks in the Text List, then convert that Text to a Number List

The way I normally do it is format the Number List like “1,2,3,3,3,0,0,etc.” So basically a normal number list, but changed to be a string of text. Then you just push that string into a Text List

1 Like

That will tell you how many uses of the card are in the deck. What it does is it lists each value that is inside the deck, then checks to see if it’s equal to the card’s Starting Value. If it is, then it will be used to say that many of the card is inside the deck.

Link to the game for easy access

1 Like

And technically the filter isn’t needed, you could do that check inside of the expression itself instead

1 Like

It made flow-lab freeze, and now it won’t refresh. Might be a minute.
It works!
Had to change some of your stuff around, but it works with my system.

huh, don’t know what would have caused it to freeze. Works fine for me, but idk the system you’re making as well so hopefully they work together fine

Spoke too soon, once I made a second card type, then all the issues started.
I thought the number going into the find would be the number it finds, didn’t realize it’s finding the first item in the list.
So now I broke the removing system.
Not rlly sure how yours is supposed to work, because it gets stuck every time. Either stops removing, or can’t add any.

I know the system works, so something must be done incorrectly. Did you directly copy and paste the code or did you do it by eye? And if possible a link would be useful.

I think the problem is happening because I have no idea what you’re doing. I’m assuming you’re building the system as I would build it, but I don’t think that is happening so the systems aren’t designed to work together. I know my system is pretty flexible, but I just don’t know what is actually being done to it or if any modifications have been made.

1 Like

Yeah when I use your game, if I click to add, then start removing some, it gets stuck at whatever number I added to. Like lets say six, then when I remove one, it goes to five, then remove another and it stays at 5, but when I add another it goes to 7.

The fourth level is all you should care about, the rest is a mess lol. Do note that this is my edited version, so if you have a way of fixing this version, that would be easier than me restarting.

1 Like

Ah ok, the issue was happening because the List Modify wasn’t being set at loading and I forgot to add the filter.

Adding the Filter set to “Greater Than 0” and the Once to set the List Modify seems to fix all the problems

Any chance you know what’s going on with the actual card selector things? If you add four of one, then add a different, then go back to adding the one with 4 it goes to 5. And also the numbers won’t show for both.
It’s like they’re checking for the same value, despite one being set to 1 and the other 2.

I’ll check it out in a sec, I’ll probably get a chance in about 15-20 minutes

1 Like

This Number set to 0 is the cause of why only the most recent card added shows it’s amount. What’s happening is that it’s set to 0 if it doesn’t match, and the last card added will only match one of those.
Also I wouldn’t use an always for this, but I would instead a Once and then have the code after this set the Label. It’s just a small optimization change, you don’t need to do that.

Doing this change also fixes the issue of it extending past 4. The reason it would go past is because, like the label, the number was set to 0, meaning the system was detecting it as less than 4.

There is still the problem of it not showing 0 but instead 1, I’ll look into that rn

What do I change, making the “done” go straight to A doesn’t change anything.

Just remove that Number connected to the “Fail” output entirely, it’s not needed

Oh, I thought you meant the reset lol.
Besides the 0 instead of 1 thing. I think this is finished!

1 Like

I mean, this works, but I’m a bit disgusted by the code here lol, I’m sure there is a more effective solution (probably just following the original example a little more and handling things as it’s removed instead of constantly checking the entire deck).
I’ll see if I can fix it later tonight or tomorrow, but I’d recommend just trying to change the system a little to use just an extra expression instead of constantly running this check of what cards are in the deck.

Anyways, happy to have helped, @ me if you need anything else

1 Like

I mean this is the only way I know, I’ve never really used lists and wanted to break my comfort zone a little.

1 Like

Oh no, I meant the code I just made as a hotfix to the 0–>1 issue, not your code

Did you ever find a solution for the staying at 1 issue? I haven’t really worked on it, but just reminded myself I never fixed it to go to 0.