If you hit the jump button in my game then while you are in air if you hit the ball you can then jump again. How do I fix this?

Every collision has a directional setting, so you can disable the collision from the top, if you click on it

that helps but doesn’t fix it, I tried making it so only the things I wanted the character to jump on could turn on the jump switch (see burger character and jump button) but this problem is still there

It appears their you try changing the shape to rectan

yeah the shape is a rectangle.

I took a look at the burger character, and the jump switch is set to turn on when a collision happens with any object. This means that contacting the ball will turn the switch back on.

for the burger i fixed it so it only gets turned on with the floor and the opponent but the problem is still there.(use buttons to jump)