Hi and thank you for any help you can provide. My game that I made is so massive that I broke Google Chrome AND shockwave flash when making it! Please help me undo the lag of doom!


I am interested in this as well. Does anyone have any input on the limits of Flowlab and how much it can handle (and how to optimize for size?)

You broke chrome? Not surprised. On good computers might not crash, but, it will lag. So, my question is what are you using?

@todorrobot, pun intended?

@meburningslime - post a link to your game and I’ll check it out, you may have something that’s a simple fix.

@todorrobot - the answer to the limits question is really “it depends”. There are not many hard limits. You can probably grind your entire game to a halt with not that many objects if they are all running pathologically expensive logic in tight loops. On the other hand, if most of your objects are static, you can have tens of thousands of them - the bottleneck at that point becomes the loading and startup time.
@TheUltimateBepis I’m using an updated mac. It has NEVER had any lag problems.

PS the @Crigence critique has rated me 1 because of lag!

@grazer are there any resources that you or anyone knows of that discuss (for lack of a better word) “conservation” in coding? I’m approaching coding/game logic from a complete novice stand point and don’t even know what to look up to find people talking about writing clean and precise logic (in whatever programming language… not just Flowlab logic).

ARDUINO: Sunfounder


it’s kinda expensive for the kit that goes along with it but worth it.


Hey @meburningslime - I took a very quick look and it appears that the majority of time is being spent on particle collision. Do you have something that is using an emitter that may be emitting lots of stuff?

The player emits tools. Some enemies emit projectiles. A boss clones itself. A demon throws magic. Pots break and drop items. Chests open and drop items. The whole entire background even emits enemies!

How do I fix this!!?!?

Hey @meburningslime - I took a closer look at your game. I think the biggest problem is that there are like 5000 individual sky objects that are all dynamic physics objects for some reason. The physics calculations for all this are very expensive, so if I turn off the physics for the sky (disable movable, solid, gravity and collisions) then that eliminates the lag for me.


@meburningslime , when going into the objects, you see the following: movable, solid, gravity, and collisions. So you would just have to turn those off. But woah, that did lag A LOT. I really wanted to see what it looked like, but I couldn’t.

Dude, your thing just white screened.
That said, I’m using a 1st generation chromebook, 2010 I’m guessing.

You may have an easier time accessing the game directly through the editor link: - the editor itself doesn’t lag.

Wooow, I’ve never had anything crash like this before @grazer and @meburningslime … That was just… Wow… You actually need to take of the physics on the background objects because that was really bad, almost at the point I thought I couldn’t use my computer anymore :lol: