Position bug please help :[

Red is the object, blue is the position the game thinks it’s at. Yes, I tried reloading.
So I have one overall question:

If you’re looking at block type, it’s getting the position from the block above it which looks like it’s at 80, 80.


but it’s not the same block, it just looks the same

Hmm I’m not sure, but a link would help look at the problem…

1 Like

Also, I checked the console and nothing’s wrong there
@grazer this might be a real problem…

I believe this is a bug related to inputting into the position block, making the extractor to output x for extracting x and y.

The solution around this is to use the position outputs instead of using the extractors:

1 Like

This is 100% a bug. I just fixed it here, so it will be resolved with the next deploy.

More info:
Objects with no physics used to always extract a value of “0”, but a recent update gave them the ability to have the actual x & y position extracted. Apparently the y position in this case is wrong. You should be able to work around the issue in the meantime by giving the object in question a physics body. You can do this by enabling either movable, solid, or collidable in the physics settings.


OMG HE FINALLY FIXED A BUG I SAW :scream: :scream: :scream: :scream: :scream: