Possible bug with GUI bar functionality

To recreate:

  1. Go here: https://flowlab.io/game/play/588397

  2. When you press W, A or D the intention is the lander will move up, left or right respectively, and consume one unit of its 1,000 fuel per one press of any of those buttons. It does this as expected when you play the first time after going to https://flowlab.io/game/play/588397

  3. Click “Open Editor”. Click “Play” from the main screen of the editor. Again, it functions as expected.

  4. Click “Open Editor” a second time. Click “Play” from the main screen of the editor. Now when you press W once you lose what looks like 20 units of fuel right away. Sometimes this happens on #3 and sometimes it takes until #4 of this list. I’ve included a screencast if that helps.


To fix it, connect a once to a number that is set to 1000, and then connect the number to the bar

That seems to have corrected my omission. I apologize for misfiling this as a bug. Thanks as always for your help, jngthree. It means a lot to us newbs.

To be honest it was something that I figured was a bug, but because it was so small and easy to fix, it wouldn’t be that much of a problem.

Don’t worry about it man. That’s what the forums are for!

@jngthree Curious about a related question. So I want to give the lander 1,000 fuel when it touches a fuel pad. I followed the same logic you showed me for the starting fuel: I simply added Collision with the top of the fuel pad thinking that would feed another 1,000 in each time the lander touches it. It does not.

Screen Shot 2017-02-07 at 9.03.30 PM

Yes, but connect it to “in”
Because your setup will give the player 1001

Hmm, connected it to in and it’s still not working. What am I missing?

Also, anticipating another question should I get the above working: I’m hoping there’s a way I can do it so that hitting a fuel pad can never push the total above 1000 i.e. if the lander hits it carrying 500 already or something).

With the current setup, it shouldn’t push above 1000, because you are setting the value rather than adding.

@Melville not that big of a deal but if the bug you had earlier is fixed then you should add FIXED to the title of the post so people know the bug has been fixed or helped with :wink:

@henf25 I wouldn’t do that. Only @grazer has done that for bugs he’s fixed. I say that because this could actually be a bug. I’d like to say it’s not because it would allow level transitioning while keeping health.

@henf25 I’m not sure it’s a bug though: probably just me being too dumb to get this working haha. But I’ll defer to grazer before marking it as solved.

@jngthree do you have any idea why my current setup still doesn’t result in the fuel pad adding the intended 1000 to the lander?

@Melville you set the collision of the pad to the top
set it to the bottom

@jngthree That worked. I feel dumber than ever, but thanks for all your help!

@jngthree @jngthree oh whoops, well i guess dont listen to me anymore :joy:

@henf25 Haha, I’ll listen to you if you have the winning lotto numbers or know a sure fire horse to bet on.