RPG Top down movement problems.

hello, i’ve been having some problems with RPG movement. i’ve been copying the RPG example’s character physics from the help page and modifying it to make my own RPG. my only problem is that movement is very flawed. i’ve changed the character and game’s physics to make it identical to the example, but all of the alterations had the same effect. when i try to move in various directions at the same time, sometimes the character gets stuck and can only move in a “line” (no left and right or up and down) until you let go of the keys. i haven’t seen this anywhere else, and in every RPG flowlab game i’ve played the movement is perfectly fine. what could it be? and if this helps in some way, i’m trying to make an EarthBound styled RPG. thank you!

Post a link to your game and we can take a look.

nevermind! i fixed it already but thank you!

ok, now i have another problem! whenever my character moves to the right and the animation plays there’s a split second where the character reverts to it’s original sprite and it’s really bugging me.
the game: https://flowlab.io/game/view/1022335

This is because you have a Keyboard trigger set to “repeating” connected to the “play” input of your animation. This means that the animation is constantly trying to restart. You could fix this by unchecking “repeat” on the Key trigger, and set the animation to “loop” so that it continues playing.

thank you!

and last question (sorry if i’m bugging you) but can you flip sprites? like have the same sprite for left and right walking but inverted?

(i’m kind of aware that you can do that, but i mean, copying and pasting a sprite to flip it and then edit it so it can be seen as a different angle?)

also, is there an option so that when i move right or left (or up) it doesn’t go back to the origin sprite and it just stays at the direction?

Try checking the “stay on last frame when done” box in the animation settings panel. This should prevent it from reverting to the default sprite.

yes, i tried that and it didn’t work!