Saving game problem

This is what I did:

Created new object “Shop#1”
Made a sprite
Made a behavior bundle with some stuff
Created new object “Shop#2”
Used same sprite as Shop#1
Used same behavior bundle as Shop#1 but edited it a bit
Trying to click OK but the button isn’t working so I just clicked at the game grid to close the pop-up
Test game
Refreshed page
Shop#2 is gone, Shop#1 is still there.

I tried to make Shop#2 again but it didn’t save again.

I know right! I hate it!!

This seems bad :frowning:
I tried to do what you did:

-Created new object “A”
-Made a sprite for it
-made behavior bundle (with nothing in it)
-Created new object “B” and used the same sprite
-Used same bundle and added some random stuff
-I was able to click OK
-Tested game
-Refreshed it, they were both still there

I once had objects disappear, but if I refreshed twice (or once if I just opened it) it came back.
I saw what @jngthree you said about numbers but I don’t really understand :confused:
I think I’m doing this wrong

Oh… now I see. I made a new game and the player sprite+behaviors disappeared once I refreshed…
@grazer you really need to fix this… or Flowlab’s losing a lot of points :frowning:

@Latif3 - I believe that this is fixed. It was kind of a weird one.

The issue was that the “#” symbol in the object name was causing a problem when saving to the server. I have just deployed a new build that should take care of it - please let me know if it doesn’t fix the problem.

@Luminous700 - what sort of problem were you seeing? It should have been working fine with objects named “A” and “B”.

That worked fine. It was another game.