Tell me if this game loads for you

Since last November, I have gotten comments, messages and notes that my game Diamondsion Assault doesn’t load anymore. I’ve also been unable to get it to load, which is the primary reason it has dropped on the most popular games page. grazer tells me it loads perfectly for him, but for me, and many others, we only see this stuck loading bar for 20 minutes until we give up. I even bought a brand new Windows 8 and changed internet service, and tried at my library. Same result every time. Maybe you just have some sort of super permissions, grazer.


Hey Mhx,

Try it in the new engine and see if that makes a difference - to force an older game to run in the new engine & editor, append “?v=2” to the url, like so:

Also - try clearing your browser cache before testing the new engine, if you haven’t done that already - you may have an old version cached. If that fixes it, let me know.

I also see in the logs that there is an error in the Mhx object’s behaviors, I’ll try to see if I can get to the bottom of that.

So the game works in the new engine, but all the behaviors of Mhx are gone. I did once have you make a back up copy for this game a long time ago.

doesnt work

The game loads but the Mhx dont appear on game

Ok Mhx,

I looked into this a bit more, and discovered the problem with Mhx’s behaviors. Basically, he had so many behaviors that the save data would no longer fit in the allotted space (2^16 or 65536 bytes). The end of the behavior data was getting clipped off, so it would no longer load back in properly.

I enlarged the available storage space so this problem won’t happen again, and I manually fixed up the behavior data file so that his behaviors load up again. He doesn’t seem to jump properly though, so either I’m misremembering the controls, or I messed that up somehow - sry :frowning:

While I was in there, I went ahead and bumped the game up to the latest engine & editor version as well.

I… I just don’t even know where to begin. The jumping doesn’t work, and I can’t figure out why. The D blasts don’t work, and the S run button teleports me below the map… I guess I have to start all over.

@grazer so I just added a run and jump bundle to fix that, and spinning and running work now, but I try using that S needle button (Idk why I can’t remember it’s name right now…) and no matter how I set the X or Y to a Position, it teleports me way off the map to the left. If I set both X and Y, if teleports me slightly forwards. I decided to give up on it, but since I got a new computer, and build to computer is gone, would you be able to get me a packaged zip of all the sprites in singles, so I can reupload them to the Android game?

The teleporting is likely due to slightly different coordinates in the new engine. The old coordinate system was really confusing, so I updated it so that the origin (0,0 position) is always at the top left corner of your game, no matter the game dimensions. This means that if you had a behavior with a specified position update, it will probably be incorrect.

I’ll zip up your sprites and email them to you so you have a copy of them all.

Alright, thanks grazer. I see this new program loads so much faster than before. Does it support custom loading screens, or will I have to pay for that extra feature? I’m thinking about just a spinning icon and a “Tip” box at the bottom for advice on how to play. If only static images are allowed, I guess that could work. One day, I want to make a minigame loading screen, something like a side space shooter in between levels, especially if it’s a long level that loads slowly.