Camera glitch and stopping animation

In my game there is a camera glitch when I jump over the spikes. Also, when I do this, it stops playing my double jump animation. Please help :frowning:
https://flowlab.io/game/play/1438331

play ultra guner

ill check it out soon and go in further inspection

ok, thanks @glithctyrus

I’m not too sure on the camera, but it seems to help to make the spikes object have a polygon hitbox…
I also recommended to have spikes a separate object from the ground so it doesnt could if you touch the ground the spike is on.

Also the proximity is turning off the animation, you have nothing turning the switch back on…
I would either recommend to use a collision or to not have a switch to turn it off because your spawning a new player.

ok, for the proximity, can you send an example @“JR 01” ? Im not quite sure what you mean.

The Proximity is turning a switch off, even if you didn’t touch the spikes…
Also idk why you have a switch to turn off the double jump animation, it should work without it.

strange

I’m asking, why do you have a switch to turn of the double jump animation?
The proximity is what turns it off…

Im not sure. Could I delete it without messing anything up?

Yeah, just connect the mailbox to the “1” number block.

ok, thanks

Did I do this correctly?
https://flowlab.io/game/play/1438331

Delete the proximity, there’s no reason to have it.

ok :+1:

It worked!! Thanks for the help but I still have another issue. My camera glitches at the bottom of the map on the double jump.

I have a theory to why the camera is like this, but I’m still not sure.
If you look closely, the objects position is is off the grid position, so jumping (after dying) in this little window seems to do it more consistently. I have never seen (or just never noticed) this before and I think @grazer need to take a look a it as well…

2020.06.21-11.50

Update: I found the issue below, but the grid does get more de-aligned the further you move away form the center of the grid.

wow, you are right. I have no idea why it is like that. :astonished:

Whenever I go into the game, it looks like it is on the grid. I would show you but I don’t know how to screenshot it.
https://flowlab.io/game/play/1438331

You can screen shot on windows with Win+Shift+S, then click the option next to the X up top.
Just scale and save it in your computer, then upload it in your next comment.


I took another look and I actually found the problem. You have 2 camera blocks fighting each other.

Instead, Cut the camera in the “Run” bundle and paste it in the “Camera Shake” bundle and delete the old one that was in there. Also after the shake, insert another timer (set to 1 w/ delay of 1) that moves the camera back to place.

It would look like this:
2020.06.21-13.26