Camera won't scroll

Hi, my daughter who is 6 is trying to get her camera to scroll. I have done everything the tutorial has asked me.

I wish I knew how to show you a screen shot. But I have added the camera to the behavior of the character. I have inputed the Right points to the edge of her entire level. But when I push play, it only shows the original part of the square and will not scroll. The auto scrolls are checked. The “camera” box is not connected to anything. Just an added behavior on the screen. Is it a glitch? I have tried restarting the page and deleting and adding in a new camera.

Any tips? It was working and then I tried added a “restart thing.” And somehow in the process I messed it up. I deleted that part to in hopes it would fix it. Even tried to “UNDO.”


Hey @PollardAcademy,

Can you produce a link to your game. (If I can’t see you game, there isn’t much I can do to determine if it’s a glitch in your code, or the engine’s.)
If not, I can make a bundle for you to import. By Camera Scrolling, you mean making the camera move with the player, right?

If you’re using a windows 11 (or 10, I think) computer, then there should be a 3-dots button in the upper-right of the screen. Press that and a menu appears. The button for screen captures should be there.


1 Like

Hello, it sounds like you didn’t actually put in parameters for the camera bundle, without these your camera will not scroll. Up/left is negative and Down/Right is positive numbers. Hope this helped.


Just post the game link here, that will make solving the problem much easier

Also, welcome to the forums!

you’ll will have to change these 4 collems to make it scroll

1 Like

1 Like

Do I just give you the URL? Of my editor? Or is there a shareable link you can click on?

And yes, making the camera move with the player.


Here, I’ll make a bundle for you to import.


There is a copy button in the upper right of my post. Use that and import it into your player.

I did this and it still doesn’t scroll. When I hit the “play” button inside the “behaviors” screen, the rest of the level disappears. Then when I hit the stop button it shows up again.

Where do I find the link to the game if it isn’t published yet? You can see above the screenshot of the behaviors. It seemed to get wonky when I added the “Lives” and “Restart” components. Could that mess it up?


Hmm… that’s strange. The behavior has ‘Autoscroll’ on and yet it still isn’t moving with the player.


Here you go. I basically made X autoscrolling using a bundle. Does this work? I extracted the player’s X and attached it to the Move X input.
I also used an expression in-between to make sure that the player is in the middle.

deleted and made a new object with the same behavers and it worked

1 Like

There is a camera behavior in the grass object, you need to remove that for it to work.

Also in the Library tab, (if you see a search bar) you can search the name of the behavior to see what objects have that behavior.


Really? I mean I was told it could do that but when I tried it, but it never worked.

From my experience, i dont think it works with spaces. I think.