Connection Error game art did not load correctly please cheek your connection and reload page

The massage above is what it has said all day the game art is fine and the game works fine till I click OK on it then it freezes the last thing I did on this game was make a background sprite the apartment I was wondering if any one could find the cause for the problem is it my fault or my Internets fault because it is rainy today also plz tell me if the message above appears for you also I was wondering if i deleted the apartment sprite completely would the game go back to normal I already deleted it off the background I have not tried deleting the apartment sprite completely because I worked hard on it but if I have to I will

Could you leave a link? yeah sorry about im just very tired right now and forgot it

Hey @grazer, I’m starting to get these more often myself in some games and something in my new test. I found a code that does this constantly in several games and I’ll leave it below the image, though I’m not sure if it helps completely.

This is what his game comes up with:

And this is the Label code that creates a similar problem in any game you put it in:


Wow, thanks for putting all this info together @“JR 01” - I’ll see if I can get to the bottom of it

yeah I’m getting that a lot too @grazer

So this message happens when something in your game cannot be downloaded for some reason. Sometimes this happens if a sprite was saved incorrectly or failed to upload because of a connection problem or something. The reason this error was added was to prevent someone from loading a game with a bad connection (failing to download the sprites correctly) and then editing the game and saving bad sprites when the connection returns.

Anyway, @zan101 - it looks like you somehow have a missing sprite for Object “New Type 10-2” on the user interface layer (missing sprites are displayed bright red). You can either delete this object if you don’t want it, or open the sprite editor and assign a sprite to that object.

@“JR 01” - your issue is something different. The server was complaining about using the character “?” in your label. I’ve “fixed” it so that the error is no longer shown, but there is still a problem. The Label block will only display a subset of ASCII characters, since that is all that’s included in the font. There is no font glyph available for “?” so it will just show as a question mark on screen.

Thank you all so much for helping me fix this problem I deleted Object New type 10-2 and it fixed it