[FIXED] I found a bug!

In SB2, the grid is set to play an animation when it detects “E .parent” or any of its children or children’s children. However it does not pick up. @grazer could you fix this asap? The special effects aren’t as good

Yep, I’ll investigate - thanks for reporting it!

No problem

@grazer did you seek it out?

Haven’t investigated this one yet - yesterday I was looking into your sound request :slight_smile:

Oh. Thanks though

Hey @jngthree,

I’m trying to investigate this issue, but I don’t understand the description. I’m looking at the grid, and I see the following collision triggers:

  • “,Player”
  • “wormhole”
  • “.laser”
  • “explosion particle”
  • “.ship explosion particle”

These all seem to be triggering, so I’m not understanding the issue.

“Laser” was originally “E .parent”

Only “E seeker cloak” triggered it

“Dual laser” does not trigger “laser” either


@jngthree - I just tried this:

  • Opened “.laser” and set its parent to “e.parent”
  • Opened “grid” and changed it’s “.laser” proximity trigger to “e.parent” instead

When I played it, the laser objects still triggered the proximity nodes. I think I’m still confused about the issue, sry :frowning:

“laser” never had a parent as it was the projectile parent, not an enemy.

Keep the prox like you changed it, but leave the laser object alone.

Also I noticed a dramatic problem in the chaos spawner… things aren’t highlighting properly, connecting the emit to something can shut it down… etc

I think i should put it on another page, but i already feel like I’m already flooding the forums, and possibly annoying some people

Feel free to start another thread for the chaos spawner issue - that way we can keep this one for discussing the inheritance problem.

I’m still not understanding the description - if I change the proximity trigger to “e.parent”, what should I expect it to trigger on? What objects have “e.parent” as their parent?

It may be easier for you to set a proximity trigger up in such a way that it demonstrates the problem, then tell me which one I should look at. That way I can see it failing, and figure out why that is the case.

Also, thanks for reporting this problem, and helping me track it down.

@grazer I did, expect anything with the letter E in front of it to trigger

Hey @jngthree - I can see what you mean now. I am investigating the issue, and I’ll let you know as soon as I figure something out. Thanks.

This is fixed, thanks again for reporting and explaining it!