Glitch with artifacts and lines when playing animation

Recently, I noticed that there are some weird artifacts when playing an animation in game. These appear as lines sometimes transparent, sometimes not. It only happens when the camera is moving and only when the camera is in certain spots. It may have something to do with the collider; I’m not sure. It might also be because of the new update. If anyone has any thoughts on how to deal with this please let me know. I have tried many different animations and I have no idea on how to solve this.


I think something like this happened to me a long time ago but can we please get the game link?


This is an issue that I also noticed and was talked about in the discord. Hopefully it can be fixed soon.


It is a very common among several projects. I’ve had it happen with static and moving objects, even ones without animation (only would happen if the camera moved). Very uncertain of the cause, and is a well-known visual bug, so I’m sure it’s being worked on. Might be a very difficult issue to resolve.



For me, when playing the game on flowlab its fine. Once exported to windows it shows some weird lines in the animations.

I fixed some of it by removing certain animations and redrawing them in the editor. Its tedious but can sometimes work.
Also, it mostly happens when i use animations imported from my desktop. When i use flowlab drawn animations, my games dont show this behaviors after exporting


@rcreger @CodeAlpaca @davidheeren1
Hi, i think i found a solution:
only works for enemies and other objects not the player

  • re-draw “basic sprite” only (the one when no animation is played) and make it smaller (look the images)
    test Problem

How to fix:

Also works if you leave it completely empty but then u cant see the position of the sprite the editor.
You can also test it and tell me if it works, if not send me a link of the game so i can test it too.
worked on windows exports