How can I test an iFrame FlowLab Game?

I keep taking the iFrame code and pasting it into iFrame testers but the game just doesn’t show up, I’ve turned off adblocker (even though iFrame still shows up with adblocker on) and I’ve even just took the embed URL and put it into an iFrame generator to make my own but it just doesn’t work.

What am I doing wrong? The embed url works but the iFrame doesn’t.

Mac | Chrome | No Adblock

What page are you trying to embed it into? Send me a link and I’ll check it out.

You literally should be able to just paste the provided code as-is into a web page. Here’s an example:


There’s no way iFrame isn’t supported on a new Mac with Chrome and no adblocker.

@grazer Have you actually tried using the iFrame code? I just tested it on a Windows PC and it still doesn’t work. The actual embed link does work, but the iFrame code doesn’t.

I’ve even used iFrame testers on Mac and PC so I know it works, but I’ve even taken the FlowLab embed URL and generated my own iFrame went to and removed all the HTML and replaced it with the iFrame code, and still NOTHING on Mac and PC. The iFrame literally just doesn’t work!

I want to release my game on my own website but I can’t because the iFrame doesn’t work at all, again not for Mac or PC, using FlowLab’s iFrame, generating my own, testing it online, putting it on text documents and saving it as .html, no adblocker, no popup blocker, nothing. Not even any errors in the Chrome console, it’s an absolute anomaly.

This just has to be a bug of some sort, I can embed any other webpage, but not the game, I mean Puffin broke after the multiplayer update so possibly iFrames did too? I didn’t see any chrome errors when pasting the code into an empty website but that could be an incorrect way of doing it, regardless I’ve tried doing it the correct way and I did see errors, but didn’t know if they were relevant.

Here’s another GIF to CLEARLY explain what is happening, this is happening on Windows as well.

Hey @PixelStudios - I’ll check it out in chrome today. If it’s not working, that’s definitely something new.

@grazer @Latif3 made a test website and he got his game to work fine, but when I go on the website on Mac or PC, it doesn’t work, even though the FlowLab editor works, the game works, and the embed URL works, I’ve got to be missing something or there’s a compatibility issue.

Edit: Not even Chrome, didn’t work on Safari either.

Hey @PixelStudios, I just did some testing across browsers (on a mac) here:

  1. Firefox works fine in all my tests
  2. Safari works fine in all my tests (but initially shows a “click to enable plugin” message that you have to click the first time you play)
  3. Chrome works fine when embedding in an https page (e.g. but does not seem to work when embedding an a non-https page: - I don’t see any errors or anything, so it’s not clear to me why it’s refusing to load in that case.

@grazer @Latif3’s test site is which is https. still doesn’t work on Chrome Mac, Safari Mac, or Chrome Windows. Latif was able to run the game here, was there a flash update or something that screwed something up? maybe Latif is on an older flash version?

Even look at which allows you test webpages on multiple browsers, it just doesn’t work. How is it that it’s not just working for me. Even using browserling?

Edit: Latif’s screenshot of evidence.

What it looks like to me, PixelPizza, and most likely a lot more people.

Latifs site is also not working for me, but the link of the embed game itself works.
Tested on chrome.

Browserling doesn’t seem to be a good way to test, since there is no Flash plugin available AFAICT. When I tried to test, none of the games worked, iframe or not.

I think the issue comes down to whether or not you have enabled Flash to run for a specific site/browser combination or not. When embedding the game in an iframe, the browsers tend to not show the “enable plugin” prompt for the embedded site. I’ve added a message for embedded frames when the site isn’t showing, so you should be able to click to run the games if they aren’t showing for you. Let me know if you’re still having trouble @PixelStudios

Also, I have no idea how @Latif3 was able to get the game working in Weebly. I have heard from lots of people that it doesn’t work, and the last time I tried it (a long time ago) I couldn’t get it working myself


Now it works

@grazer Ill check it out soon, thank you. Also there is flash installed on Windows 7 Chrome for Browserling.

Pretty sure this fixed the multiplayer issue on Puffin (not entirely sure) I ran a multiplayer game on it.

@grazer Yep, works now! Thank you so much, it’s coming along on my site very nicely. Just wish I could remove the loading screen or input a custom one, but I’m just happy to finally see everything working, just thank you so much again.