How do I make a sword (SOLVED)

In my game I want to have enemies and stuff but how do I make weapons? I made a sword but when I did the attachment it made a clone of my character that doesn’t move properly, help.

Idk what the proximity’s y would output to
The green play button tells you how to make all the basics in flowlab. Go to the editor and copy whatever you want!

I did that and copied the follow script then it was kinda glitchy so I made it follow on y and x because my game is a top down game but it still seems kinda glitchy at some times so idk what to do, here’s my game

Here’s a a pretty good game made with follow scripts.
I couldn’t find an X and Y script for your boss 1, so that might be the problem.
If that doesnt work, use the pointer scripts I use in SCP:World’s End.

I added in the pointer scripts and it made the boss go upside down and stuff so idrk about that but yeah.
I’m gonna try making the player itself attack bc rn only the companion (that spawns out of nowhere) can attack because it makes a duplicate of the player and gives it the sword, instead of attaching to the actual player so idk about that

Ok. The X follow script works. Just duplicate that and set them to Y. MAKE SURE THE PROXIMITY ALSO USES Y lol

What the X was for the original one.

Nvm that, I thought u meant like duplicate the number, and not all of the stuff.
I did a copy of the stuff and set it all to y but it’s doing the same thing that it did earlier so idk what to do about that
Edit: I figured out that he follows the character, but only for a very small area, so I upped the proximity area and that works, I did the same for y and x but he only follows the character left and right and not up and down so not too sure what to do with that part
Edit 2: I realized the problem is that the y proximity is not contributing to the equation for whatever reason, i then noticed the equation was not set so I fixed that but the “y” proximity still won’t do anything
Edit 3: I realized I forgot to set the proximity to the character so I fixed that but now it won’t follow the character’s x or y so not sure what to do

Make sure that the Y is set to Y velocity, not X velocity.

of course it’s set to y velocity, earlier it was only following the x, i tried making it follow the y as well, but now it wont follow either so idk what’s going on

@ImTotallyNotBkGaming this is odd.
It works if you walk far away up then come back down, but not at any other time. @grazer @“JR 01”

I guess people usually only use enemies following for platformer maps and not top down maps.
I just had an idea that it could face the way of the character then move forward but you need to set forward to a specific direction so Idk how that would work

@ImTotallyNotBkGaming no, I have made numerous games with this setup, as have many other people. I might be overlooking something.

Well can you try putting that setup into my game and see if it works

I figured it out, I just needed to change the duplication for y, I had to put the extracctor value to track the y but i didnt know i could do that but yeah, fixed it, it works perfectly now

Ok good. Glad I could be of help!