How do I stop objects having any friction on each other (I've changed all friction to 0).

There’s a problem where the player still sort of “clips” or sticks onto other objects briefly when they move towards it, I’ve set the player and said object to have no friction and they’re still briefly sticking to each other.

(If the GIF isn’t playing, view it here )

As you can see the ball sticks to the pillars a little even though the friction is 0, this causes major bugs in my game and bad physics.

Here are the assets…

Screen Shot 2018-08-15 at 12.35.45 PM

Screen Shot 2018-08-15 at 12.36.51 PM


P.S. No, changing the objects shape or bounce didn’t fix it.

This is a silly question, but did you try reloading the page to see if maybe the settings didn’t get updated for the existing objects?

@grazer I work on this everyday and the settings are how they should be.