Im getting an iOS error

I get a iOS error when I try to export Mobile App. I have all the correct files uploaded. Please help
iOS error

1 Like

Are you using an ios device to export this? Tbh i’ve never really exported any games before so I don’t necessarily have a clue, but maybe @grazer could help you out since he kinda made the system.

Yes, macOS Big Sur v11.1

Try either cloning the game or refreshing the tab.

I’ve tried both and I’m still getting the iOS Error.

1 Like

Hey @robweb - I’ll check it out. Gettaing all of the signing files assembled correctly can be really tricky, so it’s not at all uncommon for it to take multiple attempts.

Hey @robweb, you didn’t say which game you were exporting, but I assume you’re talking about “LevelsTest1”. If that’s the case, then your problem is an invalid .p12 file. The other files look OK, but you’ll need to generate a .p12 that is paired correctly with the certificate you’re using in order for the signing process to complete.

Hope this helps.

You can export from any device, you only need an iOS device for testing once the export completes.

How do you get the .p12 file? I don’t see that in the documentation

When you created a CSR to generate your certificate, it created a public/private key pair to sign that request. You can export that key pair (no password) as a .p12 file from the Keychain app.

I’m still getting the iOS Error and I uploaded the .p12 file. I think that is link should be in the documentation for the .p12 file -,Certificate%20from%20a%20Certificate%20Authority.&text=Click%20Continue%20within%20Keychain%20Access,Click%20Done.

What else could be the problem?

I just looked at the build logs, and the problem is still a mismatch between the .p12 key file and the certificate. This time the .p12 is actually a .p12 file, so it’s getting closer. Please make sure that:

  1. The keys you are exporting are the same ones used to generate the certificate you’ve uploaded
  2. The .p12 file has both the private and public keys included
  3. For step 1 and 2, make sure that the certificate matches the one used in the provisioning profile

It’s often easier for me to start over from the beginning, making sure that I carefully make a copy of each file as I go to ensure that they all match - especially if you have multiple certs, provisioning profiles, and keys.

The process can be frustrating, but these signing steps & files are required by Apple to make the app installable.


Hey, this error is still coming up. I’ve done the steps over and over again. I’ve clear the cache in Chrome, I’ve made a clone and tried the exporting process in Safari. And I’m still getting the error. Can you look into this please!

1 Like

@grazer help this poor man

@robweb - the error is the same:

 0 valid identities found

This means that either the cert itself is invalid, or more likely that the .p12 file does not match the cert, or does not include the the two correct required keys.

1 Like

Still getting the error. I checked my cert through - here and it is valid. The p.12 matches the cert.

But listed under the certificate is only the private key in the Certificates section of Keychain Access. The public one is not, it is listed in the Keys section of the Keychain Access. How do I get them both under the certificate?

Also in the Certificates section of Keychain Access, it says that my certificate is not trusted. Could that be the issue? How do i make it trusted?

1 Like

Did you see my latest post, on Feb 21?

Thanks Grazer, the non-password .p12 and the two Apple intermediate certs, that you suggested. Fixed it.

1 Like

Awesome, glad we got to the bottom of it :+1: