Infinite Loop bug


I was just coding some special objects in my new game and the game bugged. First, when the code came to a randomizer, the code stopped working, all of it. Second, when I tried to see what was wrong (Pressing esc), the game screen flew off to a random spot on the screen and the tab was frozen.

These bugs are really worrying me, I took all of my day today coding that object and now I can’t do anything on the game. I think this bug is due to some sort of Flowlab update, but I can’t be sure.

Why is this happening?

Good day,

That appear to be an infinite loop of some sort. Not a direct loop because you don’t have the warning, but the same thing happens when you attach an object with itself


Where is the infinite loop?

This is the code for the object.

This is the receiving code in another object:

I don’t understand.

1 Like

Is it sending the numbered messages back into the same object? (Second image)


No, that’s a different object. It’s tasked with spawning a racecar, that’s all. Oh holy freaking ****. I’m an idiot. I’m an idiot. I’m an idiot.

I don’t even need any of that code, lol. Only the saving of the global, my goodness.

Oh wait, maybe I still do. Hmm… it should work smoothly.


You know, instead of sending multiple numbered messages, you could just send multiple numbers into a single message and that value is sent to the receiving object. I use it all the time as switches to tell if a feature or ability is active at or not. It can also act as a global in terms of sending numbers, but instead of it being universal across the level like a global, it’s only shared between the objects you have messages linked to.

Basically, just an input into a number and the number into a message. Whatever value is put into a message, it sends it to the next object.


Wait, you can write down a message using code?

Also, I watched the code, all bugs happen here:

1 Like

Do you have a link to the game?

I could take a better look at the entire context of what you’re trying to do, cause there could be some loop being caused by outside sources as well.

1 Like

Oy, yes. I have the link. I was initially trying to keep the game private, do you mind if I PM you?

Yeah, that’s fine. I was replying on another discussion so I couldn’t respond sooner, lol.

1 Like

I’m used to waiting a week or so for a response, so it doesn’t matter.


1 Like

Like maniac said, you can just send a value through a message.
A game link would be needed to find the exact issue though. As long as the messages in the 2nd image isn’t sent back to self or updates the global, it should be fine (but it’s not, so I’m assuming it’s one of those errors)


Maniac Pumpkin solved it in a PM, thanks for trying though!
At least, he found a bug-free way to do it.

I think that was the case, but I can’t be sure.

1 Like