Invisible code?

My character has no logic (except for some that restarts the level when hit by a fireball) yet it is still able to jump. The bad part about this is I can’t alter the jump height because there is NO NUMBER. Pls help. (btw I have tried refreshing)

Hold up, I think there is no other code. I have a device checker and I manipulated a bit to check if there was logic. There wasn’t anything about movement

Did all of the logic just vanished? I think I know what might have happened, I think that most of the logic randomly moved somewhere inside of the editor but when you open it it only shows the midpoint where the level restart is so somewhere really far away is the code. Which this happens to me, but usually the code just spawns off screen and is still accessible. Only when I add a new behavior. If that made any sense.

That’s about all I can get out of what happen. I honestly don’t know what went down, lol. Sounds like a job for @grazer.

@ManiacPumpkin, yes, the code did just vanish. I will check “into the farlands” and see if I can find it. Like I said tho, I did try manipulating it, and It seems like there is no logic.

Wtf just happened. I will explain the situation

I try scrolling into the far lands of code. Didn’t find much. I scroll back in and my original code from the screenshot above scrolls into view. WHAT THE ****!?!?!?!

If you ever feel like there is some logic out of view, try the zoom in/out buttons. That will center the window on your behaviors.

If you have objects that work without code, or is acting like it has a mind of its own, check to see if those objects have a parent selected to them.


Sorry @grazer, already tried that
@JR01 I am checking

No Parent’s, sadly… :sleepy::sleepy::sleepy:

Ok, so I just decided to make a new character with new logic. Do look into that tho @grazer, cuz it could possibly be a bug

Could you leave a link?

1 Like