New to Flowlab and "Connection Error, Unable to save level update." keeps showing up

I’m very new to Flowlab as I’ve just made an account not too long ago. The first time I went to the tutorial for making a game, the message “Connection Error. Unable to save level update! Please check your connection and reload the page” keeps appearing every time I do anything. From changing the name of the game and gravity in the settings, to simply adding and moving sprites, this message keeps popping us every time!

I’ve reloaded the page several times and when I do reload, any progress I made on that save is instantly gone! I’ve tried restarting my computer and even logging in and out of my account but it still doesn’t get rid of it. I’ve tried making a new game but to no avail. And worst of all, it won’t even let me delete previous saves!

My WIFI isn’t even the problem as several of my friends who also are using Flowlab are doing just fine with their games and we are using the same WIFI connection.

Hope there is actually a solution to this problem, or maybe its just me.


This exact same thing happened to me not too long ago.

The dreadful story

I was building my first game that I called ‘Red Moon’. I had built an enormous level and had a good basic game setup. After I had been working on the game for about three months this showed up: Connection Error, please reload the page and try again. I couldn’t get it to go away no matter how I tried.
Eventually I just settled on deleting the game. I just couldn’t get the game to work.

The reason for this Connection Error

I’m quite sure that this error is caused by; Opening two accounts and editing the same game at the exact same time or opening two of the same account and editing the game.

For some reason this error happened to me when I only had one editing tab open. I have no idea how to fix this error. I would tag grazer… but I wouldn’t. Maybe a pro or moderator would know how to fix this problem, or even how it starts in the first place. I’m sorry that I don’t have the solution for the problem.

1 Like

I have no idea why this is happening. Can you send a link to the game? I’ll @grazer because as long as your connection is fine it should be working, so maybe this is a bug.

Have you tried to connect to your account on a different device?
Also if you could send a video of this happening that would greatly help with finding the issue


Check you’re library in each game layer and see if there is a red square object. If there is, you need to edit or delete that object.

Another thing you can try is signing out and back in. Is this a or normal account or a student account? Teacher can lock games out too.

Also try messing @grazer on here or discord and he can find the error.


I’m pretty sure I singed in and out multiple times. I might be wrong. The time it happened to me it was long ago.

Is the

an object made by the user or by the game as a warning. If it was made by the user, then I can understand why it would crash in my game. It was called ‘Red Moon’ after all and there were a large number of red objects in it…

I’m sure that Grazer would know the reason for this bug.

Nah, the red square error :red_square: is a object made by the user but the image got corrupted and defaults to a 1x1 red square. And one of the errors would keep showing up until you fixed it.

If you don’t see any of those then its not that error. I believe this is something grazer will have to look at.


Oh, ok. So, the red square error is a sprite glitch… I don’t know what else would’ve caused the Connection Error. We’ll have to wait for @Adellius to respond. Has the Red Square error happened many times?

A big “Connection Error” sign appears on the screen when this error happens. It’s pretty noticeable.

Anyways, we shouldn’t post much more on this topic until the creator of the topic posts again.

Hey @Adellius - please post a link to the game so I can take a look

1 Like

@grazer Here’s the link to the game: Flowlab Game Creator - New Game

From what I’ve seen there no “red square” i could find. I’ve recently tried signing in and out of my acc, and even making a new acc with my personal email. Still, same situation still persists in that separate acc.

I have a suspicion that it might actually be my device that’s causing the problem. I haven’t really tried going to Flowlab on a separate device but I’ll try it.

1 Like

This seems like maybe a problem with your device or network? I am able to log in as you and go through the tutorial OK using that game with no errors.

If you try it on another device or network and it still fails, please let me know.

1 Like