New Update (bugfixes only)

I just deployed a new update (version 1.812). No new features, but several annoying bugs fixed.

  • I reverted to the old bitmap editor font, after realizing the new one looked terrible and blurry on non-HD displays
  • Better rendering quality when in the editor
  • Fixed background tiling in negative x & y direction, and made scrolling much more efficient
  • Fixed attachments when using objects that do not move, or have collisions enabled
  • Handle rotations properly for static objects (static objects emit in the correct direction now)
  • Behavior node display updates
  • Removed right-click context menu
  • Fix problem with cloning not disabling on mouse up in some cases
  • Fix problem with dragging level while wheel menu is open
  • Fix problem with dragging behavior nodes not releasing as intended

Please let me know if I introduced any new problems when making all these updates :slight_smile:

@grazer I have a clock in one of my games and the thing is supposed to stay on. And every minute- an hour passes. BUT if you walk up to the door you have to start the minute over. I dont want that. Can you make the timer stay where it is between levels

Sweet!! could you also look at this, on kindle’s there is a side bar that normally goes away during a game, but its always there in my game.

Finally You Fixed It.

Found another bug, the tutorial doesn’t work. When you get at the point where is says “click behaviour bundles”, the button is out of the little circle, so you can’t click it. Idk if my explanation makes sense but it’s really irritating if you’re new to the game and don’t know how the creator works.
Hope to see it get fixed!

Hey saam, thanks for letting me know :slight_smile:

I broke that when I adjusted the behavior window size, but it’s fixed now!

Can u look at my problem

Also you never fixed the bundles spawning we out of the screen

Also You Never Fix The Copy And Paste
Music Into My Games! I Just Press Right-Click On My Laptop
It Not Show Up!

hyperthender, can’t you just do ctrl+V?

Saving in game works, and if you use R to load the save state, you go straight back to where you left off. However, refreshing the game, or closing it, places you back to a set position by a river. I haven’t figured out if this is a bug of just something I did wrong crossing the behaviors.

Arrow keys - Move
S - Enter Ship (Can’t save while in ship)
D - Dock Ship
Space - Save Game
R - Load Game
X - Fast Travel Home (Where you should first load up)

Iv’e tried the game on my tablet and phone and they both start you in that river position, but the saving works, its only while in the editor this happens.

Never mind on the working on the other devices. If I exit the internet, I start right back by the river, not where I saved.

I just remade my entire save system, it works now.

When I entered the editor the whole screen was white and there was no software