Oh no help sprite is wack

My sprite is now pretending to not exist, and I can’t click on it in-game.

Hey @hihilogic - the best way to get help is to post:

  • A link to your game
  • A description of the problem
  • The name of the object that is misbehaving

The leaderboard button shows in the editor, but I can’t click on it, and whenever I add it to the game it still doesn’t exist

Whenever you have a problem like this, you should try playing the game from the behavior window. When I do that, I can see that the button clicks are working just fine.

It appears that you do not have a level selected in the “Next Level” block, so the mouse click doesn’t actually do anything when it activates.

1 Like

What if its because they’re stacked i saw 3 trophies stacked

Its still not working for me

Grazer is better he checks everything (i thought you already selected a level)

1 Like

Oh no hes right

Grazer help himm

I tried unstacking the trophies it doesn’t work ;-;

Ok, it finally let me delete the blocks, but now it doesn’t go to the next level


So will you just delete the non-working one and remake it?

maybe. It’s not my primary concern, just a level transporter. I’ll first work on the leaderboards, then try to fix this

1 Like

The MouseClick is connected to the NextLevel get input instead of go


Ugh. That was pretty dumb

Lol now we learned our lesson (PAY ATTENTION)

well, the sprite also wasn’t deleting. BTW, would you mind testing this?

1 Like