"Only trigger once" option on Proximity is missing

The “only trigger once” option is nowhere to be seen.

I need it to trigger a character’s dialogue and it’s not there. Where did it go?

Just put a out to off switch

How do I do that?

Just a switch where the output goes into the off input


Its missing because you use the “check” input now.

why though? I don’t understand why that happened.

Because it’s better, don’t question it B)

Because having it “Always” running would create lag instead of having an option to when to trigger it.

1 Like

Ok, how do I use the check input to only trigger the Proximity once?

For an output of once, you can put a switch before the proximity that turns off from the proximity. That would greatly improve performance rather than having a dead proximity behavior.

Ok, how would I do that?

1 Like

You dont need both X and Y. Delete the X and Y links and link the X up to the In on the Switch. For the out on the switch, connect it to the alert.

Sorry but it’s not working for some reason. Did I do it wrong?

Check is needs to be used for it to work.
I’m on mobile so it’s low resolution.


How do I connect that to what I’ve already made?

1 Like

Connect the X to the show… duh.