OUTPOST OMICRON - Post Flowjam Dev log

Now that the Flowjam is over (Shout out to @PixelPizza for the triumphant victory! Well earned!) and I’ve had a chance to get away from my game for a week or so, I wanted to come back and make it a little more playable. I had a lot I wanted to get done before the Flowjam deadline and in classic hyperfocus fashion, I totally lost track of time on tiny details instead of getting things like “the ending” and a clock that didn’t show negative numbers working correctly. >:(

Speaking of clocks… the day before the deadline, my clock worked ok. It went to “9” instead of “-1” like a clock is supposed to. Then, as I was doing some frantic last minute adjustments, I screwed it up somehow and caused the negative number error. Oh well. That’s just the way jams go. It’s like setting up your cake for judging on “Nailed It” and watching it flop over just as the curtain is pulled back LOL! (Watch that show on Netflix! It’s hilarious! ).

So, after making the opening cut scenes skip-able ( you’re welcome!) I tried to fix the busted clock. I worked out a pretty good system and was starting to tie some difficulty increase to the functionality, when I refreshed my game… and … all my new code was gone. An hour’s worth of code, kaput. BUT! It was suddenly working like it did before I screwed it up right before the jam… over a week ago!

I’m glad it’s working like it used to, but between my Craptastic Comcastic internet connection and the Flowlab gremlins, I have no idea what’s going on. Other code that I’ve added recently seems to still be there so it’s really strange that the specific code inside my “clock” behaviors would revert back like that. @grazer have there been any recent server issues or should I chalk this up to lousy connection?

Anyway, thanks to everyone who played my game during the jam and for those who voted. There were some really great entries and it was cool to see so many people come out of the woodwork to compete.

I will be updating Outpost Omicron as time and interest allows. I’ll try to put up an “under construction” screen when I’m working on it.

Play it here. Feedback is welcomed.

Thanks for playing!

I really like it! looking forward to future updates and eventually a finished version

I’m super happy to hear that you’re working on Ooutpost Omicron some more - that game really is fantastic.

The logic loss is scary and a bit concerning, I know losing work is extremely frustrating. There was no recent server update that should have had thst sort of effect. I’m inclined to assume that this was a network connection issue, but there has to be a way for the editor to handle this better if that’s the case. I’m assuming you weren’t getting the obnoxious warning beeps and yellow flashes that you get when the game is locked.

Yeah, when I submitted my game, I was working so hard I forgot to test play it and realised my mistakes when it was too late, So I’m going to fix my game and continue working on it as well. And can I say, i thought my game had a chance at winning, and my greatest concern was your game. I was unable to even play it due to it being so complex and all i did was review your log and thought, “Well I’m done for”. So glad to see your improving it further. You put a lot of work into it, I can tell @todorrobot .

@“The Kodex” thanks! Part of my updates are going to be making the controls more intuitive. I wanted to do weapons upgrades/animations and a variety of shot angles, but that was just too much work and it bit me in the end. Im going to add some of that stuff soon, but I realized I didnt need all the various angles to make it fun.

@grazer no worries. It happens. I know its been discussed before but is there a chance that there will ever be an offline version of Flowlab that doesnt need connection and runs from the desk top?

@todorrobot - I won’t say never but it’s not likely to happen any time soon since the server components will not be at all straightforward to bundle up for the browser.

@grazer ok, it’s happened again. I was trying to work out the mechanics of making my opening cut scene skip-able with a repeated press of the spacebar (press once to go from opening title to “darkness” text
press again to go to the “halfway text” press again to go to the “press space” text and then once more to go to the game) …and was struggling with it for about an hour, testing it in the live behaviors testing window and nearly had it worked out (maybe?) THEN I hit refresh to test it from the main play screen and it reverted back to my original code. All my progress and trial and error was gone and I’m too frazzled to be able to remember what I’d done to get it (close to) working.

I notice that when leaving a comment here it gives a “draft saved” timestamp. Can we get something similar in Flowlab that tells us that everything that is current is saved? My internet may be a bit dodgy at times, but it wouldn’t have been offline so long for it not to have saved any of my work. How can I be sure that my progress is being saved as I’m doing it? Are there time-stamps and save states on the Flowlab server that you have access to? When you have a chance can you take a look at Omicron and see if there’s anything weird going on?

Code in question (what’s left of it) is in the behaviors of “omicron opening text” in the Intro level. It is not currently working how it’s supposed to and is pretty borked. Any insight into the code-loss issue (or the solution to the skipable intro code) is appreciated. Thanks!!

@todorrobot - After you reported losing work previously, I added a bunch of new alerting to the latest editor release. If behaviors are unable to save, it should be really obvious.

Behavior saves only happen when clicking the “OK” button on the behavior window. This is probably a dumb question, but is it possible that you had the same window open the whole time and reloaded the page before clicking OK?

I’ll check out your game and see if maybe the issue is a loading problem or something? I’m not sure what’s going on here, but I definitely want to get to the bottom of it.

Also, I’ll take a look at the logic itself to see if I have any suggestions for how to fix up the logic itself.

I apologize for the loss of work (again), and hopefully I can get this figured out ASAP.

@grazer I thought about the clicking OK thing last night after I wrote this, and wondered the same thing. But I know I definitely backed all the way out and refreshed several times with the work I was doing at the time. Thats whats so weird. I was making progress, refreshing as I went but then on one certain refresh it reverted back to a big chunk prior. Every cold restart adds a play to the play counter on the game page, so is there a way to check the play log to see how often I restarted and what the save state was at the time? (I dont really know what Im talking about here but its where my brain thinks some evidence might be). Thanks again for digging deeper. The data loss seemed to happen both times when I was really struggling with the logic on a particular part and testing a bunch of different things.

The plus side is that typically after a set back like this, Im able to come back in the next day and nail the code on the retry. I just havent had a chance to take another stab at the opening sequence yet. I appreciate you taking a look at the code as well to lend some insight. Thanks!!

Hey, this is interesting. Just so I’m sure I understand, when you say “refreshed” you mean you reloaded the browser tab? And you did this multiple times and the behaviors were saved OK for a while? If that’s the case, then maybe there is a problem with the behavior data being corrupted somehow or not loading properly, and I’ve been looking for a problem in the wrong place.

@grazer yes. Reloading the browser tab. Sometimes I even close the tab and reload flowlab and go to my game from play/edit buttons on my games page. Some progress had been made and saved and then reverted back to a slightly earlier version.

Ive had this happen before on a smaller scale when Ive accidentally created an infinite loop in my code. Flowlab would crash and then revert back to a safe non-loop version on the reload. I dont think I created an infinite loop in the most recent two losses though, but perhaps something else I did caused a fatal error without the pop up warning.

My code gets pretty thick sometimes because Im still figuring out how to streamline things (I havent learned how to use parent blocks very efficiently or how to use bundles at all yet). So if while youre looking around, you have any code style/layout/consolidation techniques or critiques to offer, Id gladly take them. Ive only just gotten to the point where I can kind of read other peoples code to see whats going on. And Im trying to keep the top left to bottom right run order in mind in my own code.

@todorrobot - The new release from tonight has an update that I hope will prevent this from happening in the future. I suspect that maybe your browser was somehow loading a previously cached version of the behaviors instead of your latest update, so I’ve modified the network communication to prevent this.

Hopefully this takes care of the issues you’ve been seeing, but please keep me posted if this sort of thing happens again, I’d like to make sure I resolve it 100%

@grazer super thanks! Ive done a bit of updating since the last data loss and have not run into the issue since then. Crossing fingers its gone for good.

Also, I received my sticker in the mail yesterday! Thanks for that and the kind words. Its nice to know someone else out there lost some coin to Xenophobe in the arcades as well!!