Ran outta room

When I was making an animation for a sprite, I somehow ran out of room and the play and stop animation buttons on the right where it shows the frame previews, were like, pushed off to the right past the browser window.

So I expanded the window and it started showing my game in the background instead of giving my buttons back and I came to realize that the sprite editor window is just a “pop up”(?) instead of an actual screen so i can’t get my buttons back without deleting a few frames. I also can’t delete frames sometimes.

My buddy had this same issue, he’s gonna post a screenshot of it. Thanks in advance.


problem 2

cant delete the frames towards the right, to get the buttons back. Would appreciate any help()

Why do you need so many frames? They are all equal.
You can simply click on “repeat forever” and it will loop the animation.
Also the sprites have a limit because if you too many it will lag and probably crash.

IF you really want the animation so big (which I don’t recomend and you should take the other option)
do various animations and make them to when finish start the other.

But don’t force more sprites in only one animation.
Animations behaviour can auto loop

It doesn’t look like your animation needs that many frames. It seems to repeat itself, so just use loop. Animations have a size limit, because they map to a single sheet of paper, so while small sprites can have more, because big animations fill up the paper faster, you’re still bound by the length of the screen, unless grazer adds a scroll tab or a new way to use bigger longer animations.

@PixelPizza Why is there the option to have so many then instead of having a limit lmao

@“Mhx Ar” It is a cryo chamber and the animation doesnt need to repeat. Its the intro, and it just unfreezes and the door comes up and the character comes out.

In that case, you may want multiple animations to play after each one is done

thanks brofams

Get a camera