Some weird stuff is happening in my game

-there’s supposed to be two separate jump animations for jump and double jump, but it’s always the normal jump animation

-the player can infinitely jump against walls.

these are things I’m having trouble figuring out.

For the infinite jumping, remove all but bottom collisions for ground

It seems that the global “jump” signal only goes up to one.

You could fix this by using either a toggle switch instead of a global signal, or adding a delay in the raycasts setting the global number to 0

The raycasts were detecting the ground when you jumped, which is the reason for the delay

@Lyndon_Bork I’m using raycasts for jumping, no collisions. and what delay do you mean?

sorry for late reply

The collisions detecting when you hit the ground. How it works is; when you collide with the ground, it enables the character to jump again. That collision object is currently set to collide on all sides, instead of the bottom of the character.

When I said “which is the reason for the delay” I meant - that’s why you add a delay between the raycasts setting the global signal to 0. They were setting it to 0 right after the first jump, which isnt what you want

@Lyndon_Bork thanks for the clarification