Weird Extractor Behavior

i went back into my game and i checked the behaviors and all the extractors for every object deleted and when i try to choose a new extractor (i know im supposed to choose the type and object) and when i select the type, the object drop-down is blank. and i have so many extractors, it would take forever to replace them. I’m literally freaking out right now, i tried replacing the extractors and its still not working.

If youre trying to extract X/Y coordinates from objects other than the one youre modifying, I would consider using a proximity

i cant use it @CrimsonBlackGames

its sad to say this but @grazer , could u revert my game back to how it was at 5:00?

The object your extracting must be in the same level.
Could you leave a link to the game what object is doing this?

it is @“JR 01”

@grazer ?

Hey @XXD3G - I don’t have hourly backups of game data, they are only daily.

Also, only Indie users get to make priority support requests - sorry :frowning:

“what object is doing this?”

all of them @“JR 01” and -_-

Well I ask @XXD3G because I dont see the objects in the game…
It must be the spawned zombies your talking about.

If the object isnt in the level or what its searching for isnt in the level, it will not find it.
Instead, Extract this X and Y in the player (or whoever your trying to extract) and message the enemies.
The zombie will use a mailbox instead of an extractor to get the targets X or Y.

Thank god! @“JR 01” its working now, thank you so much!