Why do I keep on having these stupid glitches that appear after the code already worked.

Hurray! It’s me again… I really like this, I seem to get just stupid glitches that make no since. The best part? This was working like normal before hand, then it just decided “it’s time for me to break” even though it was working before hand. I didn’t even change anything in the code! it just broke!


Second level.



ALSO, How come when a object using velocity to move, hits a object using position to move, the position object constantly moves towards the direction that it pushed? Even when you adjust the drag of the object, it still happens.


It seems to work fine, the reason why its showing an output on a closed system is because you have other cloned objects using the same system but with the switch on. The switch itself displays what that object is doing, but the cords displays all interactions between all of the cloned objects.
The problem is that you have another S soldier with the switch on.

The velocity issue is because the object using position is actually being teleported to it’s next position, so it’s outputting NO force against the object using velocity.

slow your roll there @“JR 01” I was 100 percento positivo that there was NO other units outputting.

When I deleted all the other S units, the 1 worked. I’ll check again later, but I think it may be the one by the tree…

Hey people, this is still happening, and not with the same game. @grazer please help!

Whats the link to the other game?

@“JR 01” https://flowlab.io/game/play/1154412 the enemies

It’s doing this because the last enemy is stuck on the sign, so it just stays on the first switch.
Just make the sign not solid, but enable collision.

There is another problem though, the enemies stop after a little while.
I think it could be the sprites get stuck after a little while, but I have found a way around this.

This moves the character if it ever gets stuck;
filter is not equal to and the timer is set to 1 with the repeat of 1.

You do know all the problems on this discussion is that the behaviors shows what’s happening between all the (same) objects, right?

that’s not how it wors for my other games @“JR 01”, it shows if it’s on or off ONLY on that object.

@“JR 01” Can you send me the same screenshot on discord? Flowlab dosnt allow me to full screen it.

Yeah, the switches (indicator) works for that specific object you selected
but the wires that connect everything is shows all the outputs from all the (same) objects