Why is my music bugging? [SOLVED]

In this game’s menu, I have a controller object that plays music and controls the UI. When a player first loads the game, the music doesn’t start. Does anyone know why?
When I press R to reload the game and go back to the menu, the JUMP and Tetris buttons don’t work.


If you’re starting it with a Once, most browsers will block sound until a mouseclick on the page


Oh shoot. That’s why when I tried to start JUMP, the music started a second time. Is there a way to fix this?
Also, when the player presses R, which is supposed to bring them back to the menu, the two right button’s hover systems don’t work anymore.

1 Like

I’m glad you mentioned that since I didn’t even know, lol.


I would recommend a start screen that would say click to start or maybe press any key to start.

I’m not sure if pressing a random key on the page would work or not, but you could try.

I know a lot of featured games (professionals) add that to the beginning of their games and that might be what it’s for.

1 Like

Oh, hmm… Ok. I’ll try that.

1 Like

For smaller indie games, it’s typically a nice touch and you can also use to load up a short introduction before the menu, such as your logo or anyone else who helped in the development of the project.

Plus it makes any project more polished.

1 Like


Hm… I don’t have a Logo Yet. Maybe I should make one…


Now the music won’t if I go into the editor and back. I suppose that’s better.

Best not to make your players enter the editor. Going into the editor just tells the browser that you’ve clicked the page already

1 Like

If the players don’t go into the editor, then they can’t get to any of the games because the buttons DON’T WORK ANYMORE! Everything I make breaks.

I gtg now, but I’ll try to find the issue later. This is the E Game thing right? (making sure I have the correct link)

1 Like

Yeah. Flowlab Game Creator - E Game Collection
Here’s the link.

Some of the switches in the buttons are turned off and there’s no input to turn them back on. So, I’m not sure if it’s because that game is currently closed or not, but that may be why it’s not working.

That’s because I don’t want people to be able to get to the games just yet. I mean, the hover-over system doesn’t even work.
Oh wait, now they work. What the heck is going on?

1 Like

Only the Vironia one is turned off so I’m assuming you’re working on it. The rest seem to work fine for me, but take a second to find and load up the page.

Your browser may have a blocker to prevent pages being opened, since I know Opera GX on my laptop had that as well.

I can open the tabs just fine. All of the hover systems should work, just not the links.
For instance, the switches on VB2 and Last Stand are on.

When you hover over the buttons, it’s just supposed to reveal the name of the game, correct?
I’m not having an issue with any of them, seems to be working fine for me.

Ok, it works half of the time. I’m fairly sure it works when the player starts the game initially, that’s mostly all that matters.
Thanks for your help @ManiacPumpkin!

1 Like