Mouseclick over and out

This is simple.

When I turn the cursor off, the outputs Over and Out on the mouseclick behavior don’t work. Here’s a link to my game. If you press 1, 2, or 3 and hover the cursor over one of the three buttons on the Main Menu, it doesn’t activate the ouputs:
Is this a bug?


I’m pretty sure this is because of the mouse objects covering the actual mouse.

1 Like

How do I fix it?

I would make sure the custom cursor is set to polygon so it only takes the shape as what’s drawn, that way the actual cursor should be able to go through and be detected by other objects.
If that don’t work, then you may have to update the sprite for the cursor and open up the middle a bit more with this method.
If you don’t like the design, you could just make a hallow circle and add an animation on top of it so it shows the same cursor you have, but the actual hit box is what the object primarily was.

1 Like

The custom reticle is in the UI.

Even the UI are still able to detect the mouse location and since it’s in the UI, it prioritizes itself above the game layer objects so it’s blocking the actual cursor from being detected by other game objects.
You should still be able to change the hit box on it though.

And if you’re still having issues, just use the proximity to detect the custom cursor instead of using the mouse in and out. So it actually detects the sprite of the new cursor than the original.


Yeah, I was thinking about that. That could actually be better than over and out.

1 Like

Wait, I see what you mean. There’s no hitbox settings for UI, let me take a gander real quick.

1 Like

It is so hard not having proximity and raycasts in the UI layer.

1 Like


UAHHHHHH!!! I’m going to be using a dozen or so proximities. AHH!!! Never mind, you can’t even detect User Interface objects, so this won’t work.

I’m starting to wonder if I should turn off the cursor or not… will that even do anything?

1 Like

Make a separate sprite in the game layer? Just have it invisible?

1 Like

Also I realized that proximities won’t detect UI objects, unless they use a Parent object from the game layer and you detect that parent object.

One issue I think may be the cause is the fact that the entire menu is one entire sprite, and for some reason it’s detecting the title, the play button, and the two menu art sprites all as different pieces. Also it may be bugging out cause it’s trying to detect the mouse on a very large sprite.

I’ve never had issues with this, even while using custom cursors. I ended up making a custom cursor in the game layer and I just use it so it detects better.

1 Like

I’m a free user, I’ve used enough objects already.

Will that work the same as if it was in the UI layer?

With enough animations and switches, you can technically have a single object act as hundreds.
A good tip to do this is to give each object a custom name so lets say the name is 1, it’ll be a ground block or whatever, if the name is 2, it’ll become a door.

It’s pretty tedious, but it’s a great workaround for free users. I sometimes use it a lot when I’m struggling to have objects.


Ha, I just did that today. I used the object name, extracted it, made it one button, and so on.

1 Like

Wait nevermind…

So it does, but the game layer object only updates when you move your mouse. So if the character has a camera on them, and you move around, the cursor will stay put in the game coordinates instead of screen so your cursor can go offscreen until you move it again.
One solution to this is to make your cursor become invisible when the player is moving, but become visible again, when you move the cursor yourself.

I did this for a top down project that used the cursor to actually move the player.

I do that sometimes, but I only have one base block anyways.

Hmm… The custom cursor or the PC cursor.

1 Like

The custom cursor.